Attack From Mars VPX

VIRTUAL PINBALL Forums TABLES, DB2S,ROMS,MEDIA Attack From Mars VPX

This topic contains 292 replies, has 107 voices, and was last updated by  Scritley 3 days, 11 hours ago.

Viewing 15 posts - 106 through 120 (of 293 total)
  • Author
    Posts
  • #82605
    toxie
    toxie
    Participant
      • Posts 41

    @g5k: great stuff! but i recommend to set the screen space reflections value to something like 0.05 or even disable it (0), as that reflection algorithm/hack does not fit your lighting tricks very well, so the reflections look way to bright in 10.5.

    #82807

    Ben Logan
    Participant
      • Posts 358

    Beautiful table guys, many thanks!

    Quick question for anyone who may’ve seen this before:
    When I hit the saucer and the table lights dim/flash like they should I get what I would call ‘banding’. Horizontal stripes from top to bottom of the screen that are uneven in their brightness.
    I think the new Batman table did this a little as well.

    I have the newest VP and the newest dll. Maybe this is just my system not being fast enough?
    I have an i5 and GTX 1050. Thanks

    If you haven’t already, try enabling vsync and disabling desktop composition in video options.

    #83102
    g5k
    g5k
    Participant
      • Posts 127

    Great Job my friend I really see the original table in my hands… but I have got a problem, flippers buttons not works, launcher coins etc works, only flipper not… any idea?

    To those posting their flippers don’t work, please read the instructions before posting. This is as easy as it gets you just need to read and update your dll OR set usesolenoids=1 right at the top of the script in the highlighted area if you don’t want to update your dll. Thank you

    #83134

    Ben Logan
    Participant
      • Posts 358

    You are patience personified, g5k!
    :D

    #83362
    g5k
    g5k
    Participant
      • Posts 127

    I know everyone is super excited and a bit of anxiety for those of you not running hardware that can cope properly. Rob and I are changing a few things over this week and should solve all of what is being raised here, so whilst I’m not replying to all the findings we are reading and the majority of the problems are all tied to performance drops that are then causing the rom to get out of sync with what’s going on. There will be some fancy rob code to avoid the balls getting out of sync, some optimisation of a few things that will make a big difference. Stay patient and hopefully more of you will be able to play with less issues.

    I did however never set out to support everything, I built the table to take things further and as a result some of you simply won’t be able to play the table without better hardware. Sorry but I feel it is more important to take things forward than hold them back for the lowest common denominator. If it was a commercial product that was being sold I would have a different view and go for maximum support at the expense of some features but for now I want it to look the best I can make it.

    Stay tuned ~

    ps. Please don’t use the rom currently linked here, it’s missing sounds.
    This is the one you want.

    https://www.vpforums.org/index.php?app=downloads&showfile=1340

    #85163

    Ben Logan
    Participant
      • Posts 358

    You guys are absolute champs. I totally appreciate the fine tuning toward supporting a wide variety of machines. That said, I just ordered a GTX-1060 upgrade. I agree with your philosophy of taking things further. Super thankful for AFM and this community.

    #88862
    g5k
    g5k
    Participant
      • Posts 127

    @g5k Been doing a bit of debugging around the saucer hits – I think it’s actually one of the lamp callbacks. Removing this line for me has yielded a MASSIVE improvement:

    SolCallback(23) = "SetLamp 123,"

    changed to

    SolCallback(23) = "" ' debugging

    Strobe maybe?

    123 is def a flasher (UFO flasher off top of my head) so disabling it will help performance as they are flashing large textures, not just vp lights. If that helps you enjoy it better for now go for it but once we’ve adjusted hopefully you shouldn’t need to disable this stuff unless you are really low on hardware spec.

    #91106

    stephen turner
    Participant
      • Posts 6

    hi
    Well i have a strange problem, the table works fine if i start from the visual pinball editor but if i start with pinballx front end i get the “cant find b2s” popup and no backglass… if i clear the nvram i can play once with the backglass and the next time i get the same error ??? ive been searching and trying allsorts to no avail for the last 3 hours ……… Everythings upto date and like i say the table and fast flips work fine from the editor
    Thanks in advance

    Have you updated PinballX lately? I had that issue on a few random tables until I updated my PinballX

    hi
    Well i have a strange problem, the table works fine if i start from the visual pinball editor but if i start with pinballx front end i get the “cant find b2s” popup and no backglass… if i clear the nvram i can play once with the backglass and the next time i get the same error ??? ive been searching and trying allsorts to no avail for the last 3 hours ……… Everythings upto date and like i say the table and fast flips work fine from the editor
    Thanks in advance

    Have you updated PinballX lately? I had that issue on a few random tables until I updated my PinballX

    i updated and still no luck , thanks for the help

    #93270

    Thalamus
    Participant
      • Posts 211

    @steve2607 : Since you’ve already updated, it sounds like the issue is best asked over at pinballx forum.

    #94025
    g5k
    g5k
    Participant
      • Posts 127

    @Stephen Turner

    There is a script changed needed to make it work with popper. It will be included in the update. Rob found I had controller calls happening before TableInit and that was causing B2S problems so if you wanted to move those in the script to after tableinit it might solve your problem.

    #94349
    Tom Tower
    Tom Tower
    Keymaster
      • Posts 1576

    correct 113b rom is now available :bye:

    #95996

    Greenman
    Participant
      • Posts 7

    Running an AMD RX580 in 1080P with 3 screens and it runs flawlessly. No slowdown.

    What a beautiful table. Hats off to you G5K. :good:

    #101233
    ganjafarmer
    ganjafarmer
    Participant
      • Posts 24

    Anyone succeed To run it with a 32bits windows ?
    Things its impossible, crashes everytime i try To load it…

    32-bit can’t handle more than 4GB memory. This is the problem my friend.

    #101752

    stephen turner
    Participant
      • Posts 6

    @Stephen Turner

    There is a script changed needed to make it work with popper. It will be included in the update. Rob found I had controller calls happening before TableInit and that was causing B2S problems so if you wanted to move those in the script to after tableinit it might solve your problem.

    thanks for the heads up :) , i managed to solve the problem by un checking the brute force setting in anti aliasing in video options …. everything works great now on your table . Thanks for this great table

    #103213
    Fwiler
    Fwiler
    Participant
      • Posts 31

    Just incredible work. I love the detail put into this to make it look realistic. True artists that understand the importance of light to dark transitions for better dynamic range. I’ve spent so much time on other tables tweaking the lighting to get better contrast, and on this no changes needed!

    You guys deserve all the praise in the world.

Viewing 15 posts - 106 through 120 (of 293 total)

You must be logged in to reply to this topic.